История История версий

MAMP & MAMP PRO для Windows

4.1.1

MAMP & MAMP PRO
  • Улучшенная совместимость с функциями macOS MAMP и MAMP PRO Cloud.
  • Apache 2.2.31
  • Nginx 1.13.1
  • MySQL 5.7.24
  • PHP 5.3.23, 5.4.45, 5.5.38, 5.6.0, 5.6.37, 7.0.0, 7.0.31, 7.1.0, 7.1.20, 7.2.1, 7.2.8 (for PHP 7: Windows 7 minimum with SP1)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 5.1.3 & 4.0.7
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.2.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.8.3
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.4.1
  • gd 2.1.0
  • zlib 1.2.8
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8

4.1

MAMP & MAMP PRO
  • Добавлена функциональность облака
  • Улучшен запуск и остановка серверов
  • тексты упрощены
  • Назначение кнопок адаптировано к общим правилам для Windows
  • улучшение пользовательского интерфейса (кнопки, выравнивания, расстояния, кадры, ...).
  • улучшение отображения (размер, фокус) инструментальных окон базы данных
  • "Мой Webstart" теперь откроется в новом окне/вкладке.
  • Расширение PHP PDO (PHP Data Objects) теперь активно по умолчанию
  • Установка
  • Улучшение графического дисплея
  • Исправление отображения некоторых флажков (Windows 10)
MAMP
  • Улучшение отображения окна настроек
  • Коррекция отображения номера версии MySQL в справке
MAMP PRO
  • Исправлены ошибки, возникавшие после смены пароля MySQL
  • Устранена причина возможного сбоя программы при восстановлении резервной копии
  • Устранена причина возможного сбоя программы при удалении хоста
  • Устранена причина возможного сбоя программы при выключении серверов
  • Устранена причина возможного сбоя программы при вводе серийного номера
  • Устранена ошибка при установке инструмента WordPress
  • Исправлена ошибка при установке дополнительных устройств bootstrap
  • Добавлены дополнительные проверки при создании баз данных
  • utf8_general_ci теперь является комбинацией по умолчанию для MySQL
  • Microsoft Edge добавлен в список браузеров (если он установлен)
  • Логотип MAMP не отображался на странице плейсхолдера при использовании Nginx в качестве веб-сервера
  • Apache 2.2.31
  • Nginx 1.13.1
  • MySQL 5.7.24
  • PHP 5.3.23, 5.4.45, 5.5.38, 5.6.0, 5.6.37, 7.0.0, 7.0.31, 7.1.0, 7.1.20, 7.2.1, 7.2.8 (for PHP 7: Windows 7 minimum with SP1)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 5.1.3 & 4.0.7
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.2.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.8.3
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.4.1
  • gd 2.1.0
  • zlib 1.2.8
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8

4.0.1

MAMP PRO
  • Дополнительные версии PHP могут быть загружены в приложение.
  • Apache 2.2.31
  • Nginx 1.13.1
  • MySQL 5.6.34
  • PHP 5.3.23 & 5.4.45 & 5.5.38 & 5.6.0 & 5.6.31 & 7.0.0 & 7.0.21 & 7.1.0 & 7.1.7 (for PHP 7: Windows 7 minimum with SP1 and Windows Vista minimum with SP2)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 5.1.3 & 4.0.7
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.2.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.4.15.5
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.4.1
  • gd 2.1.0
  • zlib 1.2.8
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8

4.0

MAMP
  • Улучшенный интерфейс программы
MAMP PRO
  • Улучшенный программный интерфейс
  • Обновление компонентов с помощью программы обновления in-app
  • Встроенный редактор кода
  • Мобильное тестирование в Wlan с бесплатным iOS App
  • Конфигурационный графический интерфейс для Nginx
  • Ruby with Rails
  • Маркировка GroupStart Server и сервисов для автоматического запуска
  • Сервер и Динест запускают и останавливают независимо
  • Apache 2.2.31
  • Nginx 1.13.1
  • MySQL 5.6.34
  • PHP 5.3.23 & 5.4.45 & 5.5.38 & 5.6.0 & 5.6.31 & 7.0.0 & 7.0.21 & 7.1.0 & 7.1.7 (for PHP 7: Windows 7 minimum with SP1 and Windows Vista minimum with SP2)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 5.1.3 & 4.0.7
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.2.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.4.15.5
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.4.1
  • gd 2.1.0
  • zlib 1.2.8
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8

3.3.1

MAMP
  • Исправления ошибок
MAMP PRO
  • Исправления ошибок
  • Новые компоненты
    • PHP 5.5.38
    • PHP 5.6.24
    • PHP 7.0.9
    • apcu 5.1.5
    • imagick 3.4.2
  • Apache 2.2.31
  • Nginx 1.13.1
  • MySQL 5.6.34
  • PHP 5.3.23 & 5.4.1 & 5.4.45 & 5.5.0 & 5.5.24 & 5.5.38 & 5.6.0 & 5.6.30 & 7.1.5 & 7.0.19 (for PHP 7: Windows 7 minimum with SP1 and Windows Vista minimum with SP2)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 5.1.5 & 4.0.11
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.2.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.4.15.5
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.4.2
  • gd 2.1.0
  • zlib 1.2.8
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8
  • libSSH 1.6.0

3.3.0

MAMP
  • Исправления ошибок
    MySQL был обновлен до версии 5.6.
MAMP PRO
  • Исправления ошибок
  • Apache 2.2.31
  • Nginx 1.11.0
  • MySQL 5.6.34
  • PHP 5.3.23 & 5.4.1 & 5.4.45 & 5.5.0 & 5.5.24 & 5.5.38 & 5.6.0 & 5.6.28 & 7.0.0 & 7.0.6 & 7.0.13 (for PHP 7: Windows 7 minimum with SP1 and Windows Vista minimum with SP2)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 5.1.5 & 4.0.11
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.2.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.4.15.5
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.4.2
  • gd 2.1.0
  • zlib 1.2.8
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8
  • libSSH 1.6.0

3.2.2

MAMP
  • Исправления ошибок
MAMP PRO
  • Исправления ошибок
  • Новые компоненты
    • PHP 5.5.38
    • PHP 5.6.24
    • PHP 7.0.9
    • apcu 5.1.5
    • imagick 3.4.2
  • Apache 2.2.31
  • Nginx 1.11.0
  • MySQL 5.5.49
  • PHP: 5.3.23, 5.4.1, 5.4.40, 5.4.45, 5.5.0, 5.5.24, 5.5.38, 5.6.0, 5.6.24, 5.6.8, 7.0.9 (for PHP 7: Windows 7 minimum with SP1 and Windows Vista minimum with SP2)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 4.0.7 & 5.1.5
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.0.4 & 3.1.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.4.15.5
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.4.2
  • gd 2.1.0
  • zlib 1.2.7
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8
  • libSSH 1.6.0

3.2.1

  • Apache 2.2.31
  • Nginx 1.11.0
  • MySQL 5.5.49
  • PHP: 5.3.23, 5.4.1, 5.4.40, 5.4.45, 5.5.0, 5.5.24, 5.5.35, 5.6.0, 5.6.13, 5.6.8, 7.0.6 (for PHP 7: Windows 7 minimum with SP1 and Windows Vista minimum with SP2)
  • OpenSSL 1.0.2h
  • APC 3.1.13
  • APCu 4.0.7 & 5.1.3
  • Xdebug 2.4.0
  • eAccelerator 1.0
  • XCache 3.0.4 & 3.1.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.4.15.5
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.1.4
  • gd 2.1.0
  • zlib 1.2.7
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8
  • libSSH 1.6.0

3.2

  • Apache 2.2.27
  • MySQL 5.5.41
  • PHP 5.3.23, 5.4.1, 5.4.40, 5.4.45, 5.5.0, 5.5.24, 5.5.29, 5.6.0, 5.6.13, 5.6.8, 7.0 (for PHP 7: Windows 7 minimum with SP1 and Windows Vista minimum with SP2
  • OpenSSL 1.0.1g
  • APC 3.1.13
  • APCu 4.0.4 & 4.0.7
  • eAccelerator 1.0
  • XCache 3.0.4 & 3.1.0
  • OPCache 7.0.4
  • Python 2.7.6
  • mod_wsgi 3.4.0
  • Perl 5.16.1
  • mod_perl 2.0.8
  • phpMyAdmin 4.2.7
  • SQLiteManager 1.2.4
  • phpLiteAdmin 1.9.4.1
  • Freetype 2.4.10
  • curl 7.36.0
  • libpng 1.5.18
  • ImageMagick 6.8.9-1
  • Imagick 3.1.2
  • gd 2.1.0
  • zlib 1.2.7
  • libxml2 2.9.1
  • gettext 0.18.1.1
  • iconv 1.14
  • mcrypt 2.5.8